Trying to push software via Group Policy. XP Machines take the software fine. Windows 7 machines give the following:

Event ID: 101: The assignment of application Adobe Flash Player 10 ActiveX from policy TestWin7Push failed.  The error was : %%1274

Event ID: 103: The removal of the assignment of application Adobe Flash Player 10 ActiveX from policy TestWin7Push failed.  The error was : %%2

Event ID: 108: Failed to apply changes to software installation settings.  The installation of software deployed through Group Policy for this user has been delayed   until the next logon because the changes must be applied before the user logon.  The error was : %%1274

Event ID: 1112: The Group Policy Client Side Extension Software Installation was unable to apply one or more settings because the changes must be processed before system startup or user logon. The system will wait for Group Policy processing to finish completely before the next startup or logon for this user, and this may result in slow startup and boot performance

no matter how many times you reboot the system, the software doesnt push. (Some win7 works)

Solution tried:

reinstall adobe, uninstall adobe,  make sure there is no crashed shadow, -> not working

Turn off UAC control, -> it is off

Enabling Computer Configuration > Policies > Administrative Templates > System > Group Policy > Policy > Startup policy processing -> 30 secs -> still no success

Changed amout to wait (in seconds) to 30
I know it says it defaults to 30 seconds if left unconfigured but just enabling the policy worked for me ironically. After enabling the policy it defenitely fixed my problem on most every Windows 7 box we have. We now have startup scripts that actually run now as a result as well.
Currently to get the job done, need install adobe manually, deal with it later. ANyway if it is a client side issue, manual install is quicker. Just get the job done first.
Advertisements